System Status

Partial outage

Incident Report for System Status

Major Impact
Resolved

Incident resolved

Jun 4, 2026, 05:02 AM UTC
Investigating

We're experiencing issues at the moment. We're actively looking into it.

Jun 3, 2026, 08:00 PM UTC
Partial outage - Autom Status Page